Share

How to Make Siebel Tools & Webclient Work on Vista Machine

A Post By Usman Saleem –
We were receiving variours queries that siebel client is not working in Vista machines. Usman has come up with full proof solution to make siebel tools and webclient work in Windows Vista machine. In this article Usman will guide us for Siebel 7.8 and higher versions and Kunal has provided information for siebel 8.0

Steps to make Siebel 7.8 tools & web client work on Windows VISTA machines.

1- Install Orcale 10g Client for Vista (optional if you are not using ODBC)

2- Install Siebel 7.8 Tools (Right click & then run as Admin). It gets installed successfully. After Installation, first time run Siebel Tool Application (siebdev.exe) again as Admin (Right click & then run as Admin).

3- Install Siebel 7.8 Web-Client. Here mostly after 95% of installation one gets some nasty error (if you dont, say thanks to God & continue). Now comes the tricky part, Dont cancel the installation. Instead simply kill the process to avoid roll back.

4- Install Siebel 7.8 Sample DB

5- Install Siebel 7.8 Tools / Webclient & Sample DB Patches (if you have any)

6- Add Siebel URL in trusted sites of your Internet Explorer (e.g. http://usman-pc/start.swe . It should be url of ur local Siebel Webclient).

7- Set security level of trusted sites to lowest.

8- Run Siebel client & it will start work, if you get error of some missing file etc then copy Siebel Webclient folder of some working installation (XP, Win2000) & Replace it with your WebClient folder on VISTA…..!!!!

9- Retry running Siebel Webclient.

10- Add License keys…. !!!

Kindly let us know, if you experience any issue.

Note

Kunal Jaura describe the solution provided on Oracle for installing Siebel 8

When trying to install Siebel 8 on Vista the web client installation errors out with Setup Failed to run ” $(IEExecutable)

This happens because the ‘IEExecutable’ registry key was removed in Vista. To get around this please implement the following changes to the siebel.ini leveraged by the Siebel installer:

– Make a backup of the existing siebel.ini.
– On the siebel.ini file used by the Siebel mobile client installer, locate the following section searching for the ‘predeploy’ text string in this file:

[RunAfter]
QSServiceInstall = yes
RunAutosync = yes
PreDeploy = yes

[RunAutosync]
Condition = no
Execute = $(SiebelRoot)\bin\autosync.exe
Arg = /c “$(SiebelRoot)\bin\$(InstallLanguage)\siebel.cfg” /l $(InstallLanguage)

[PreDeploy]
Condition = yes
Execute = $(IEExecutable)
Arg = $(SiebelRoot)\BIN\predeploy.htm

– Here above, change the ‘PreDeploy’ parameter under the ‘[RunAfter]‘ section to ‘no’, as well as the ‘Condition’ parameter under the ‘[PreDeploy]‘ section also to ‘no’.

– Start the Siebel mobile web client installer again with these changes in place, the installer should go past the error point accordingly.

14 comments on “How to Make Siebel Tools & Webclient Work on Vista Machine”

  1. Ajay Reply

    I would like to know how to load 8.1 Siebel On the Vista – Home Premium Edition machine.

    I could get it loaded as it says that your operating system is at higher level of OS than the OS designed to match the Siebel 8.1 .
    Please help.
    Thanks
    Regards
    Ajay

  2. Pal Reply

    Please let us know, how to instal siebel 8.1.1on windows vista.
    Is this same as siebel 7.8 or any different way is to be followed.

    Thanks&regards
    Pal

  3. nanasofia Reply

    Hi!

    How about Siebel 7.5 ? Have you tried yet? Same way?

    Thanks&Regards,
    Nanasofia

  4. Usman Saleem Reply

    @ Ajay: Can you please specify exactly at which step you are getting this error? As you have mentioned that you could get it loaded

    @Pal: I have only tried this way with Siebel Tools+Webclient+Sample DB vr 7.7 & 7.8. I have not tested Siebel 8.1 or Siebel 7.5 on VISTA. You can please try this process & if you experience any error, kindly share.

    Rgds
    Usman

  5. Ashish Kumar Ashish Kumar Reply

    Hi All,

    It will be difficult for us to provide process for variour Siebel versions.

    Please come up with the issues/Error your are facing in installing siebel in Vista macines,so that we can provide you resolution and guide on the same.

    Regards,
    Ashish

  6. Sue Clark Reply

    I followed the instructions from Usman Saleem and have 8.1 working on my Vista Home Basic. The only issue I’m still having is trying to get the Sample Database license key data entered so I have a fully functioning application to do my research in.

    Regards, Sue

  7. Justin Reply

    Just a note you may need to set the shortcut for siebel webclient to run as an admin. This varies based on where you have the client installed. If it is not running and just giving an error for incorrect username/password (pretty much the only error it gives). Check you log folder. If you do not have any logs, try running the application as an admin.

    To set the application to always run as an admin go, right click on the shortcut and select properties. Go to the Compatibility Tab and check Run this program as administrator

  8. Justin Reply

    Ajay, you need to set the installer to run in compatibility mode.

    To set the installer to run in compatibility mode, right click on the installer and select properties. Go to the Compatibility tab and Check Run in compatibility mode and select Windows 2003 (Service Pack 1)

  9. Usman Reply

    Hi Sue,

    Good to hear your Siebel Tools & Webclient is working. You can add license keys by webclient & by siebel tools itself (press SHIFT button while viewing license key option & it will allow you to edit /add more license keys).

    Rgds
    Usman

  10. Usman Reply

    Hi Sue,

    Good to hear that Siebel 8.1 is working for you… You can add license keys using webclient as well as using Siebel tools (hold shift button down while going to license view option & it will allow you to edit /add license keys)..

    1. Log into Siebel Web Application. Navigate to Sitemap -> Administration – Application -> License Keys.
    2. Log into Siebel Tools. Navigate to Help -> Technical Support -> License Keys

    Regards
    Usman

  11. Kunal Jaura Reply

    To describe the solution provided on Oracle Support for this:

    When trying to install Siebel 8 on Vista the web client installation errors out with

    Setup Failed to run ” $(IEExecutable)

    This happens because the ‘IEExecutable’ registry key was removed in Vista. To get around this please implement the following changes to the siebel.ini leveraged by the Siebel installer:

    – Make a backup of the existing siebel.ini.
    – On the siebel.ini file used by the Siebel mobile client installer, locate the following section searching for the ‘predeploy’ text string in this file:

    [RunAfter]
    QSServiceInstall = yes
    RunAutosync = yes
    PreDeploy = yes

    [RunAutosync]
    Condition = no
    Execute = $(SiebelRoot)binautosync.exe
    Arg = /c “$(SiebelRoot)bin$(InstallLanguage)siebel.cfg” /l $(InstallLanguage)

    [PreDeploy]
    Condition = yes
    Execute = $(IEExecutable)
    Arg = $(SiebelRoot)BINpredeploy.htm

    – Here above, change the ‘PreDeploy’ parameter under the ‘[RunAfter]’ section to ‘no’, as well as the ‘Condition’ parameter under the ‘[PreDeploy]’ section also to ‘no’.

    – Start the Siebel mobile web client installer again with these changes in place, the installer should go past the error point accordingly.

  12. Jenn Reply

    Hi,
    Thanks for this post. Im trying to install Siebel8.0 on Vista but faced the issue about $IEExplorer. I got past this point by making the changes that Kunal mentioned, however, now I get the error that Siebel is unable to open the browser for this session. Also, if I try again, it says that there is a username/password error. I have installed Oracle 10g enterprise edition(is the oracle client mandatory?). Also, in the ODBC editor(odbcdat32.exe) I dont see any of Siebels entries! So… what could be the issue(s)?
    Thanks for your help!!
    Jenny

  13. hapneh Reply

    Hi,
    Got a problem same with Jenny. I installed Siebel8.0 on Vista Home Premium, but an issue came up with IEExploer.  Then, I followed the suggestion of Kunal and tried login again but another error came out that says INCORRECT USERID OR PASSWORD. Please help…..
    thanks!!!
    Hapneh

Leave A Reply

Your email address will not be published. Required fields are marked *

error: Content is protected !!